在InteliJ IDEA中写Dart及配置IDEA - Dart Plugin

Dart官方建议使用的编译器是DartEditor,我下载下来看下,和Eclipse的界面很相像。对于Eclipse,我是既爱又恨,爱它的稳定,恨它的功能没有InteliJ IDEA那么出色。于是我心生想法,想看看能不能在IDEA中同样开发Dart。

于是试着从IDEA的官网搜索下有没有Dart的插件,一搜还真有。我兴奋了一小下,于是毫不犹豫的down了下来,准备在IDEA中配置一番。

image1

然后install这个plugin:

image2

然后再配置下Dart的SDK位置和要运行在的浏览器。这里最好建议Chromium浏览器,Google提供的测试浏览器。

image3

注意,这里一定要勾选上你的项目,我这里的项目是down的官方提供的demo项目。最后在你要运行的html文件上右键,debug运行下就行了。

image4

我们不难看出,不仅DartEditor在调试时很便利,同样在IDEA中也是很便利的,而且我们都知道,IDEA要比Eclipse功能强很多,写起html代码简直是爽极了,同样IDEA在配置好Dart SDK后,代码提示功能也是相当的不错。

就先写到这吧,以后有想起来的再继续补充。